# Problem with mysql driver

**URL:** <https://kanboard.discourse.group/t/problem-with-mysql-driver/586>\
**Category:** Open Discussions\
**Created:** [August 9, 2019, 9:48am UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586 "2019-08-09T09:48:03Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![mjaqb](https://avatars.discourse-cdn.com/v4/letter/m/54ee81/32.png) [@mjaqb](https://kanboard.discourse.group/u/mjaqb)\
**Post date:** [August 9, 2019, 9:48am UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586/1 "2019-08-09T09:48:03Z")

</div>

Hi,

I have setup kanboard on my server. It seems to be working, but when I use sqlite driver it shows “Internal Error: SQL Error: SQLSTATE [HY000]: General error: 13 database or disk full.”. There is full of free space of disk.

I have try to switch to mysql engine - but when I do this kanboard stops working at all and shows error message “Internal Error: SQLSTATE[HY000] [2002] No such file or directory”. What’s interesting - when I change to mysql engine there is no any debug.log info (when I change back to sqlite there is debug).

How to solve this? For me it’s indifferent what engine (mysql/sqlite) I use, I want it only to work properly. I cant use postegree.

Regards,  
Michal

---

<div class="post-metadata">

**Author:** ![rafaelcamargo](https://yyz2.discourse-cdn.com/free1/user_avatar/kanboard.discourse.group/rafaelcamargo/32/279_2.png) [@rafaelcamargo](https://kanboard.discourse.group/u/rafaelcamargo)\
**Post date:** [August 9, 2019, 11:49am UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586/2 "2019-08-09T11:49:05Z")

</div>

Unless you are just testing it, I highly suggest you use mysql instead of sqlite. In order to kanboard work with mysql, it’s not just change the engine to mysql. You need to setup a mysql server and set the other connection properties on config.php: [https://docs.kanboard.org/en/latest/admin\_guide/mysql.html](https://docs.kanboard.org/en/latest/admin_guide/mysql.html)

About the error `13 database or disk full.` when using sqlite, are you using linux or windows? The error should be different if it was permission errors, but did you check that?

---

<div class="post-metadata">

**Author:** ![mjaqb](https://avatars.discourse-cdn.com/v4/letter/m/54ee81/32.png) [@mjaqb](https://kanboard.discourse.group/u/mjaqb)\
**Post date:** [August 9, 2019, 12:35pm UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586/3 "2019-08-09T12:35:57Z")

</div>

I know that I need to configure database and I dont have problem with this - its made properly for sure, becouse I’m connecting to this database from command line without any problem. I use Linux (it’s installed on Synology NAS but it’s some linux distro). I dont know why kanboard shows errorr message only with mysql driver and dont write then any messages to debug.log.

---

<div class="post-metadata">

**Author:** ![creecros](https://yyz2.discourse-cdn.com/free1/user_avatar/kanboard.discourse.group/creecros/32/156_2.png) [@creecros](https://kanboard.discourse.group/u/creecros)\
**Post date:** [August 9, 2019, 9:54pm UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586/4 "2019-08-09T21:54:46Z")

</div>

Because NAS disk drives be so slow, like molasses, that things go boink. Doubtful that’s the reason tho.

Are you using ram disks for temp folders?

---

<div class="post-metadata">

**Author:** ![mjaqb](https://avatars.discourse-cdn.com/v4/letter/m/54ee81/32.png) [@mjaqb](https://kanboard.discourse.group/u/mjaqb)\
**Post date:** [August 10, 2019, 12:36pm UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586/5 "2019-08-10T12:36:30Z")

</div>

For sure it’s not related with slownes - it has parameters better than averadge server.

---

<div class="post-metadata">

**Author:** ![creecros](https://yyz2.discourse-cdn.com/free1/user_avatar/kanboard.discourse.group/creecros/32/156_2.png) [@creecros](https://kanboard.discourse.group/u/creecros)\
**Post date:** [August 10, 2019, 3:39pm UTC](https://kanboard.discourse.group/t/problem-with-mysql-driver/586/6 "2019-08-10T15:39:57Z")

</div>

That maybe, but, it’s still a NAS and so therefore it does NAS type things, of which, includes a lot of I/O. But you’ll see those errors as I/O errors, and if using mysql, less likely than sqlite.
