Contents loss with SubtaskDescription when create task from Subtask

My experience:

  1. I have been used to create additional subtask descriptions with plugin SubtaskDescription
  2. I can create a Task from such a subtask, see screenshot below!
  3. Subtask Title will become Task title of the new task
  4. Subtask will become deleted from Soure Task
  5. :warning::warning::warning: Old Subtask Description will not be transferred to New Task Escription :warning::warning::warning:

I think there should be an urgent warning in Plugin Description and may be somewhere else. I can’t find any warning.

Your experience T Thoughts?


Subtask to Task:

My Configuration

Well, this Plugin is no longer listed in Plugins List.

“Convert to task” is a core function, it doesn’t know about the description added by plugin. The plugin should overlay this to get it to work.

1 Like

Very unfortunate and extremely strange.

I tried to contact the author of that plugin, currently without any reaction. Now I’m considering taking over that plugin as well.

1 Like

The story continues

I have tried to contact the author of that plugin, to ask him to continue his work. Unfortunately, without any success, I got no response at all. It’s sad to lose such a tiny but very useful piece of software. Therefore, I created my own copy of SubtaskDescription, I’ll maintain it from there.

You can download the first migrated version from here, there shouldn’t be any functional differences. Maybe you have to uninstall the original version first.

As usual, any feedback is highly appreciated.

@Rainer: This issue you reported above is WIP. :wink:

1 Like

Great, I will install your version, soon!

I did it!

Worked fine in several tests I did.

1 Like

@Rainer I could fix “your” issue, you can download and install the updated version 1.1.3.
Good luck, and thanks for testing. :wink:

1 Like

Great, I will install and Test next weekend

1 Like

Plugin directory entry

Finally, I got in contact with the original author. For now, he has unarchived his repo, and it appears that ho doesn’t want to free up the name SubtaskDescription in the plugin directory.
I want and have to accept his decision, so for the moment, I don’t add my repo to the plugin directory. But we’ll see, if there are more upcoming bugs or feature requests, I will rename my repo/plugin to add it to the directory properly.

1 Like

Well, I think “SubTask Supplementary Notes” might be a nice Name for your fork :wink:
I wonder what Shaun-Fong’s plans might be.

Could you please make the subtask descriptions searchable?

1 Like

When I use the plugin with the automatic action that adds a subtask when applying a category, I get this error:

Internal Error: SQL Error[HY000]: SQLSTATE[HY000]: General error: 1364 Field 'due_description' doesn't have a default value```

You could use my own version, where some issues are fixed.

Download it from here.