Database malformed error

yes it is… everything is displayed correctly in the browser console.

would you mind having a look directly ? I can provide URL and valid user credentials in a private message if you’re up for it… ? (if it possible in this board actually…?)

DM is disabled here, same as email. Social networking at its best! :face_with_raised_eyebrow:
What are your options? IRC, XMPP, Matrix, E-Mail …

Another idea or question:

Did you cross-check whether your new hosting fulfills all requirements? E.g., missing PHP modules.

Consider also enabling PHP logging.

have you tried reseting the admin password?

1 Like

@creecros He doesn’t get a “wrong password” message, but a complaint about required input fields.

Hi again,

as suggested by @alfredb, I’ve cross-checked that my hosting fulfills all requirements, and the only php module which is not installed, apparently, is ldap (which is only optional and not used in our case : in config.php the ‘LDAP_AUTH’ option is set to FALSE).

in the hosting server error log, I only find this relevant log :

AH10131: FastCGI: server “[MY KANBOARD URL]/index.php” stderr: PHP message: Kanboard: user [MY USERNAME] authentication failure with IP address: [MY IP ADDRESS]

Also, @alfredb, I can send you credentials + website url by e-mail if you’re ok to have a look ?

OK, you’ll find my email in my profile, temporarily.

got it, thanks ! will e-mail you the necessary info…

1 Like

ah, got it, must have missed that part.

here is another similar issue then:

i didnt see a resolution though.

1 Like

me neither, that’s why I’m seeking some help !!!

a similar issue was also reported on this board, as I mentioned in my first post, here : Problème de connexion (Tous les utilisateurs) - #3 by Kantime

The topic starts in French but @Kantime who encountered the bug too replied in English as follows :


I had the exact same problem lately with 1.2.12

The problem occurred after validating a dialogue box. It was like Kanboard is freezing, so i interrupted that action and the Database error occurred.

Some user have interrupted a saving command. It is an important bug in my opinion !

That should not occur at all !

I had to restore the last export of the database. So, i lost some recent data. It is not acceptable.

All i can recommend to you for now, is to make exports of the database every day at least until the problem is solved.

I believe the interruption of a saving command may have happened on our server too, and caused the bug. But since now the db is now “malformed”, I cannot empty the data from the “session” table, which I thought could maybe help ?

But I think you got rid of the malformed issue, right?

Unfortunately, I cannot log in either (of course). And I don’t know what’s going on here. I cannot see, what’s happening with the data, once they reached the server.

Maybe you should try to reset the admin password, as described in post #24.

I didn’t got rid of the malformed issue, we just don’t see it in browser response since I rolled back to kanboard 1.2.22 and the db disk image malfromed error message came only with migration shcema 126 which correponds to kanboard 1.2.23, but I think that’s what’s going on behind the scenes…

As I said in my first post :

I opened the original db.sqlite file in SQLite Expert Professional 5.4, and ran the SQLite3_analyser tool. It reported the following :
ERROR: database disk image is malformed
database disk image is malformed
while executing
“db eval {CREATE TEMP TABLE dbstat AS SELECT * FROM temp.stat
ORDER BY name, path}”
So I ran the repair tool in SQLite Expert Professional 5.4, gzipped the repaired file, deleted the corrupted data/db.sqlite file from the server throught ftp, and uploaded the gzipped repaired file via admin settings page, and got another error :
Internal Error: Unable to run SQL migrations: Running migration \Schema\version_1, SQLSTATE[HY000]: General error: 1 table users already exists (You may have to fix it manually)

So what I’d really like to do is to correctly fix my corrupted database… And I figured, if I could access it again through kanboard and make a proper dump with the kanboard settings tool, it might fix it…

I also rolled back to the previous version in order to reproduce the bug I first encountered, since @alfredb suggested I should try to solve this issue first…

You don’t have shell access, right?

unfortunately not, it’s shared hosting…

no luck here either…

i’m afraid I won’t be able to fix the maformed db issue :

the PRAGMA integrity_check SQL command on the db.sqlite returns the following errors

*** in database main ***
Main freelist: freelist leaf count too big on page 50167
Main freelist: freelist leaf count too big on page 50168
… [quite a lot of these] …
Main freelist: freelist leaf count too big on page 43016
Main freelist: freelist leaf count too big on page 43015

Which brought me to the 8.4 section of this document describing the various ways that an SQLite database might go corrupt

it reads “This problem was fixed on 2010-08-23 for SQLite version 3.7.2”

unfortunately, my hosting server is using SQLite library 3.27.2

I’ve tried cloning my SQLite db with SQLite Expert Pro, with no more luck, so that’s it, I give up and revert to the month-old backup of my db.

I’ll fill in a request on my hosting server, in case they’d be willing to update the SQLite library, and will definitely backup my db regularly through kanboard settings…

Thanks a lot to you @alfredb for your help, and also to @creecros for your interest and suggestions…

Do you know phpLiteAdmin? (I like it! :wink:) You could try to export the current DB on the server, then rebuild a new DB from the (fixed) export. Or you could patch/repair something directly on the server. You might give it a try.

1 Like

Me again…

First, @alfredb, thanks for the phpliteadmin link, I’m trying the tool now but only get errors when trying to re-import the dump I’m able to make from there.

Second, when I re-import the only working sqlite db that lets me gain access to the board, which is quite big (>50 mb) and run the vacuum command from kanboard settings page, I get the same malformed db error :

Internal Error: SQLSTATE[HY000]: General error: 11 database disk image is malformed

Since kanboard requires SQLite version > 3.7 and my shared hosting is using SQLite 3.2.7 (+ the fact that we are 5 or 6 users working sometimes simultaneously), I would like to switch to MySQL db, but I can’t make it happen, for some reason, either (looks like I don’t have any priviledged user to the db created through the dump of the file app/Schema/Sql/mysql.sql …)

i’m stalking the web server support team so that they take action on their end to help, but… :hot_face: they’re not replying so far…

This would have been my next advice. :slightly_smiling_face:

I saw that also, but have no trouble with:

Database driver: sqlite
Database version: 3.26.0