Not possible do create new task

When I’m editing any task, I can save normally. Any changes are saved successfully. But when I go to create a new task, it doesn’t save. I click the save button and it doesn’t save and it doesn’t close the window. This problem started after I changed servers, the old one was a cPanel and this new one is a LiteSpeed ​​Web Server (using Direct Admin). I believe some adjustment is needed on the server side. Has anyone had a similar problem to help me?

  • I’ve already updated to version 1.2.37 and the same problem happens.
  • The issue happens in any browser.

If I enable config.php file, the window to add task does not open when I click on plus sign.

My Kanboard installation:

Installed plugins: none
Application version: 1.2.37
PHP version: 8.1.28 (I tried 8.3, but the same issue happens)
PHP SAPI: litespeed
HTTP Client: cURL
OS version: Linux 4.18.0-513.24.1.lve.el8.x86_64
Database driver: sqlite (I tried mysql, but the same issue happens)
Database version: 3.39.4
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Hi, great to see you here!

Your issue is NOT reproducible for me with

My KANBOARD installation at All-inkl hosting

  • Version: 1.2.35
  • PHP Version: 8.3.7
  • PHP SAPI: fpm-fcgi
  • HTTP-Client: cURL
  • OS Version: Linux 5.4.0-181-generic
  • Datenbanktreiber: mysql
  • Datenbank Version: 10.5.25-MariaDB-ubu2004-log
  • Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Lots of Plugins installed

And currently I can’t remember to have seen something like that.

Did you already do some debug efforts?



Hi Fabio, welcome to the forum.

I’m not sure, LiteSpeed is a supported Web server.

I would

  • Check that all requirements are met.
  • Enable PHP error logging
  • Enable Kanboard debug mode
  • Check the logs

A list of your installed plugins would also be of interest.

Thanks for your response Rainer, I have added more information on my post. I´ll work to enable all logs to try to identify what is happening.

Thanks for your response Alfred, I have added more information on my post. I´ll work to enable all logs to try to identify what is happening.

1 Like

I found the solution. If you use Direct Admin like I do, go to ModSecurity, if you see this in the logs: “COMODO WAF: Blind SQL Injection Attack (211540)”, just add the rule as an exception and Kanboard will run fine.


Kanboard is NOT compatible with Apache mod_security