Ubuntu 22.10 - Kanboard Install Issues

I cannot get Kanboard installed for the life of me. I have tried 4 different tutorials. I always start fresh with a new vm. Everything seems to run smoothly, but I always end up at apache2 default page.

This is the last tutorial I attempted.


journalctl -xe looks good

I have flushed privileges, I have made sure my php version matches the one in the kanboard.conf. I have restarted mysql, php8.1-fpm, and nginx countless times.

I don’t know what else to do. Can someone please give me some guidance. What am I missing??


Hi wantechd77,

please doublecheck httpd.conf in the apache2 conf directory. To which folders do your “DocumentRoot” and “ServerRoot” point to?

Can you provide the browser adress which you use in your browser to connect?

Cheers, Fx

1 Like

Sorry for the late response. I got tied up with other issues.

I do not see an httpd.conf in the apache2 conf directory. I do have an apache2.conf file that did not contain either “DocumentRoot” or “ServerRoot”

I was able to find “DocumentRoot” in the “000-default.conf” file located at “/etc/apache2/sites-enabled”. It was listed as:

ServerAdmin webmaster@localhost
DocumentRoot /var/www/html/

In my browser I am just connecting to the IP address of the server locally.


1 Like

You have to make sure that your apache config points to the directory which contains your Kanboard installation. That config should listen on port 80/443:


e. g. Installation is in “/var/www./html” apache points to it then your http:// should work.

I think your config points to a directory which contains only the apache server defautl html file. That’s why you see that file in your browser.

Cheers, fx

1 Like

Thanks for the help. I ended up using a docker install that worked seamlessly on the first attempt. I do truly appreciate you trying to get me situated though. This was very frustrating for me. When I have time, I may try again on another VM, for my own sanity.

Thank again!

1 Like