Error after upgrading to ununtu 22.04

I just upgraded my xubuntu to 22.04. Running kanboard with default sqlite and apache2.

Apache2 is working since my calibre book server is running without hitch.

But when I try navigating to kanboard I get the following:
dispatch(); $runner = new Runner($container); $runner->execute(); } catch (Exception $e) { echo 'Internal Error: '.$e->getMessage(); }

So I backed up and removed kanboard and did a fresh install with latest version, but no change, same error.

The only thing I could find while duckduckgoing is this thread:

which was closed and OP told to post here, but I didn’t find any posts here containing this error.

Any ideas here what the issue could be?

I just tried to acces kanboard using Falcon browser instead of FF, which output the error pasted above, and got this similar but somewhat different error output, in case it helps:


use Kanboard\Core\Controller\Runner;

try {
    require __DIR__.'/app/common.php';
    $runner = new Runner($container);
} catch (Exception $e) {
    echo 'Internal Error: '.$e->getMessage();

Ok, I see that the text pasted above is the contents of …/kanboard/index.php. So it turned out the php mod needed to enabled in apache2. After that php> phpinfo(); worked as expected.

The kanboard login too was now available at <localhost/kanboard>, but instead of a board with cards, I just get some textbased page with links like this:

I tried rolling back to the previous version of kanboard I had working before my xubuntu upgrade (1.2.21), but I get the same issue: a page with no cards, but just a list of clickable links.

So although I realize this issue might well be something to do with either PHP or apache2, or maybe even sqlite and not kanboard specifically, I would sure appreciate any suggestions or ideas at this point as I would really like to avoid installing xubuntu 22.04 from scratch (my usual MO) as I have a couple of other things on this server that were a PITA to set up and are working fine now with the upgrade. Thks.

This is no wonder, AFAIK, calibre server doesn’t use PHP pages.

Here are my wild guesses into the blue:

  1. I’d make sure your installation has all required PHP modules.
  2. I’d flush all caches in effect.