Customizer and Gantt plugin conflict

I installed the gantt plugin. The installation was successful (I think).
I proceeded by clicking the “gantt” button, but nothing was displayed.

Then I removed the Customizer plugin and replaced it with the Nebula theme plugin.
All of the sudden, the “gantt” plugin started working.

So, I tried to resolve this unknown conflict between Customizer and Gantt pluings by looking at the directory structure, swapping javascript and css files, looking at some of their php programs, but so far
not successful.

Could someone help me on this?
If any of you have installed both Customizer and Gantt, and resolved the issue, I would like to know how you made it work.

By the way, I run multiple instances of Kanboard. They are version 1.2.9 and 1.2.13.
I experience this conflict on both versions.

Thank you in advance.

i just tested, and saw no issue. maybe i am missing something? I also don’t see anything that would conflict with it.

Also, which Gantt?
I tested it with: GitHub - kanboard/plugin-gantt: Gantt charts for Kanboard
and had no issues. (Using Kanboard 1.2.18) And just to be sure, I even went through and tested with every theme, still no issue.

This Gantt: GitHub - BlueTeck/kanboard_plugin_gantt: newer gantt plugin for kanboard
had issues, with and without Customizer

Thank you for a quick reply.
Here are the two versions I’m currently running.

Locally hosted
Kanboard 1.2.9
Gantt 1.0.6
Customizer 1.12.0

GCP hosted instance: Gantt works after replacing Customizer with Nebula.
Kanboard 1.2.13
Gantt 1.0.6
Customizer 1.12.0 (removed)
Nebula 1.3.6 (installed)

OK, I will install version 1.2.18 along with Gantt and Customizer plugins and see if works.

update your Customizer version as well. that’s a pretty old version.

Installed a new instance;
Kanboard 1.2.18
Customizer 1.13.7
Gantt 1.0.6

Now Gantt works fine with Customizer themes.

Thank you,

1 Like

fyi, customizer 1.13.7 was from the master repo, and was not an official release. I am still working on 1.13.7, and I know that the master repo you grabbed that from had issues (permission issues to be specific) that I was still resolving. Long story short, just check the repo for when I officially release 1.13.7 and make sure you reinstall.

Thank you for your comment. I will reinstall the Customizer plugin when it’s officially released.