Images visibility issue for Kanboard 1.2.22

For a new installation, I am unable to view any image (logo, task attachment etc). however pdf attachments work fine. GD is enabled in PHP PHP Info
Can anyone help me in this regard as I am unable to find any help anywhere.
Kind Regards

I have checked PHP, both imagick and GD are enabled. still no images shown and it gives error as “The image “” cannot be displayed because it contains errors.”
i have tried on different images and all have such errors.

kanboard or customizer?

The problem is with entire kanboard. the link I shared was of logo for customizer, otherwise, even images inside any task are producing absolutely same result . e.g. Login
you can login using username: test and password: password
I have tried a new installation on different sub domain but same result.

then my guess is folder permissions.

Yes, there seems to be some issue of permission. but why, I am unable to resolve as is shown normally. but same image copied to tasks folder shows error 403, where as entire folder has -rw permissions and I have double checked.

The permission problem was web.config inside data folder.

<?xml version="1.0" encoding="UTF-8"?> removing web.config makes images in above links visible now but still main problem is not resolved, i.e. images in kanboard are not visible. so the problem is web.config inside data folder. How to resolve it, I donot know. Help is highly appreciated.

needs to be -rw by web server and user and absolute.

and logo.jpg should not exist in data/files/…kanboard doesnt do that. files get renamed when uploaded for security reasons.

and both links show image to me, fyi

yes. logo.jpg was uploaded by me directly to see the -rw credentials. It is -rw by webserver as well as by user. it was not uploaded by kanboard.
Kanboard uploaded it with code 38438e2da2cd1314fb70b5fc0fe3596d4b431ac6 in same folder.
Now I have again pasted web.config in data folder to make kanboard in original state. but still images not visible inside kanboard. issue is at zero stage…

After a lot of effort the error comes to be ’
One or more documents in this page is in Quirks Mode, which will render the affected document(s) with quirks incompatible with the current HTML and CSS specifications.’
any help…