Can't attach documents to a task

Hi all,

I need some help regarding an issue I have. Kanboard works like a charm, however I can’t upload files to a task. What happens is that the progress bar sticks to 100% and I never get the message “All files have been uploaded successfully.” In short the progress bar stays at 100% forever. The only thing I can do is cancel the action. When I enable debugging I only get the cryptical entry in the logging:
[2019-05-20 08:52:59] [debug] Kanboard\Core\Controller\Runner::executeController => \Kanboard\Controller\TaskFileController::save
[2019-05-20 08:52:59] [error] File not uploaded: 6

I checked all the settings (like php.ini), but can’t find anything wrong.

Does anyone has some tips how to troubleshoot this or has the answer? I would really appreciate some help.
Kanboard is installed on windows 2016 with mysql as database and PHP7.2.7.

Thanks in advance,


Permissions to data folder, maybe?

Thx for your reply.

The webserver user (IUSR) has modify rights on the “data” folder of kanboard. So that should be correct.

The extra challenge I have is that I can’t access the production system directly. I have a test system where I have full control. On this system I can’t reproduce the behavior. If I set incorrect file permissions on the test system at least I get the message “Unable to upload files”:

and not a progress bar sticking to 100% where nothing happens.

Hope I make myself clear here and someone can help me out.

permissions is really the only thing that would give you 100% and then not go any further. If it was server upload limit, it wouldn’t give you 100%.

If you look at the TaskFileController->save(); method, you will notice, the only error message you could get there is “Unable to upload files, check the permissions of your data folder”, and that is where it is dying.

You may not have flash enabled to prevent the second error from showing, would be an explanation as to why you aren’t getting it.

9 to 10 odds, permission issue.

Although, your’s is actually failing here, odds 5/10 permissions now…just not to the data folder:

[error] File not uploaded: 6

Error #6 is tmp folder issue:

  • is your upload tmp folder set in php.ini?
  • permissions to that folder?
  • does the folder even exist?

thx again for your reply, this is helping a lot to troubleshoot the issue.

The tmp folder for uploading files is not set:

assuming “upload_tmp_dir” is the correct setting.

And if I try to reproduce the error on the working test system that fails. In other words I set the upload_tmp_dir to a location where the webserver user has no rights. Still I can upload files. Guess this tmp settings has nothing to do with this issue.

Also I compared all the PHP settings of the working and non-working system. The only useful difference I see is the path environment setting of PHP. This isnt set in the non working system.

Any other suggestions?

The thing is, error value 6.

Its telling you what the issue is. I promise it’s not lying. If it’s not set in php.ini, I think it just uses /temp on the base directory, and if you don’t have write access, error value 6.

1 Like

Thx for narrowing this problem. I will look further into what tmp folder exactly it uses. I’ll give a notice when its finally solved.

It’s clear for me now and I could reproduce the behavior.
With the help of process monitor I could log the write actions. The following:

  • if “upload_tmp_dir” in php.ini is not set the system will use the default tmp folder which is c:\windows\temp
  • if “upload_tmp_dir” is set it will use this folder. But when the webserver has no right to this folder it uses the default tmp folder
  • if both tmp folders are not writable I’ll get the permission error

I’m sure I can solve this now on the production system.

Thanks again for your help!