Can't upload attachments, but screenshots work fine


#1

Hello,
I am having a strange issue: I can’t attach documents to tasks.
Attaching a screenshot with Ctrl-V works fine, so it seems the file server permissions are correct.

The file attachment screen is stuck at 0%. I have tried multiple file formats, with the same result.

Can anyone give me some tips for debugging? I couldn’t see anything in the logs, but maybe I don’t know what to look for.

Thanks!

Application version: 1.2.8
PHP version: 7.2.15-0ubuntu0.18.04.1
PHP SAPI: fpm-fcgi
OS version: Linux 4.15.18-9-pve
Database driver: mysql
Database version: 10.3.12-MariaDB-1:10.3.12+maria~bionic-log
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/71.0.3578.98 Chrome/71.0.3578.98 Safari/537.36


#2

is it possible your server has an upload size limit that is causing your issue…?


#3

I’ll take a look, but I was trying with really small files (30K).


#4

If there is a file file size limit, it should show up in your logs, like:
2019/02/13 18:59:56 [error] 14#14: *10 client intended to send too large body: 9870 bytes, client: 172.17.0.5, server: localhost, request: "POST /?controller=TaskFileController&action=save&task_id=1&project_id=1 HTTP/1.1", host: "projects.nachostudio.ml"

I would imagine, just about any issue, should show up in your logs, even permission issues, but if it can save a screenshot, I’m not thinking it’s permissions…unless maybe it’s database related, check you DB logs…?


#5

Ok, let’s pretend this never happened… I just realized after selecting the file, Kanboard still waits for me to confirm the upload by clicking on the Big Friendly Button right there… :smiley:

If you don’t tell anyone, i won’t.