"Attach Screenshot" never saves large height/width images (SOLVED)

For some reason, whenever I attempt to upload a screenshot:


It never appears to work. I press “Save”, and it loads for a second and save button pops up again, nothing is actually being saved. At first I thought this might be an upload limit in PHP, but that’s not the case as Xenforo has no issues uploading the images. Then I thought, maybe a directory permission issue but that doesn’t appear to be the case either seeing attachments work.

Maybe MYSQL then? But my old SQLite version has the same issue. And seeing there’s no “Issues” section (installation doesn’t fall in this department) I thought I’d be posting it here.

NGINX logs are empty, so no errors. When I enable debug, I don’t really see any “debug” file (not even in the data directory), unsure if it’s being generated on the fly (even with zero logs) or requires data for it to be filled.

Using latest kanboard that was released 2 days ago, with the following:

Application version: 1.2.11
PHP version: 7.3.8-1+ubuntu18.04.1+deb.sury.org+1
PHP SAPI: fpm-fcgi
HTTP Client: cURL
OS version: Linux 4.15.0-54-generic
Database driver: mysql
Database version: 10.3.17-MariaDB-1:10.3.17+maria~bionic
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36

Help is appreciated.

------ EDIT -------

It does appear “small” images are working width/height wise. Can anyone enlighten me why larger files (above full HD) won’t upload, but smaller ones like 256x256 does?

------ EDIT 2 -----

Apparently adding

client_max_body_size 32M;

Works when adding it in the site’s file. Odd though, as max_body_size is already set in the PHP file and also listened to according to the PHP info file. Case closed, I suppose? ^^