Upgrade to 1.2.7 did not replace previous version number


#1

I upgraded our Kanboard installation to the most recent version (1.2.7) from 1.2.3. I followed the upgrade steps outlined here: https://docs.kanboard.org/en/latest/admin_guide/upgrade.html. Upon completion, the version in Settings > About still shows 1.2.3.

Quick rundown of our environment:
Ubuntu 16.04.5
Database is running on MariaDB 10.2.20
web server (handles SSL): NGINX 1.14.1
value in schema_version table for version: 133

I verified that web root is set to 1.2.7, and it seems as if the upgrade completed – I had two plugins which required reinstalling (actually, it turns out that one is no longer maintained, but the second re-installed successfully).

I tried running cli db:migrate by hand afterward to see if that make a difference. Here is the the command output:

./cli -vvv db:migrate

Current version: 133
Last version: 133


#2

OK… mysteriously enough I solved the problem myself. For an unrelated reason, I stopped/restarted MariaDB and I noticed that there was a slight UI change in something in Kanboard the next time I went in (cannot recall exactly what). However, that suddenly had me wondering if version number might be correct now. Sure enough, now when I go into Settings > About, the version shows 1.2.7. Odd, but I’ll move forward and not worry about it.