DefinitionOfDone plugin not showing on my list of plugins

Hello Community,

Anybody encountered an error with the DefinitionOfDone plugin wherein it doesn’t show on your list of plugins? Tried reinstalling it multiple times and also tried both versions on the plugin as well still the results are the same. Please help. Thank you!

Hello, welcome to the forums!

What version are you using for KB? It is set for KB version >=1.2.32 so that could be the reason.

If you desperately need it, maybe check with the developer on GitHub in the repository to see if the plugin will work with older versions.


Upon checking our current version is indeed 1.2.32. Already tried using older versions (all versions since there are only 2 as of the moment) and none of them works. Could it be because of something else? Dependency maybe?

Here’s the specification of our machine that hosts KB as well;
Ubuntu Linux 20.04
Apache 2.4.41
PHP 7.4.3
MySQL 5.6

I’m sorry I’m not sure how the plugin works in a technical way, you would need to contact the developer of the plugin.

From my side, try installing PluginManager and also KanboardSupport and see if anything is shown out of the ordinary. That’s how I troubleshoot plugins for my KB setup.

You can create an issue in the repository GitHub - Chaosmeister/DefinitionOfDone if all else fails.

Okay got it. Thank you!

Can you install any other plugin?

Yes I was able to install other plugins I am only having issues with this particular one

I’d enable the debug.log to check why the initialization fails.

1 Like

I enabled debug.log and got this error:

[critical] DefinitionOfDone: Unable to migrate schema for the plugin: DefinitionOfDone => SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘definition_of_done’ already exists

Should I just delete the table being flagged or do I need to do something else? Also I haven’t executed any migration files, not sure if this one works like Laravel where I have to run one

Don’t do anything here, migrations will be run automatically.

You can delete the table, if you have nothing to lose within, and then retry.

1 Like

Got it thanks! Also created an issue with github, will post any updates or resolution here for future reference.

1 Like

Meanwhile, I also tried the DoD plugin, but encountered several, maybe minor issues in my test installation. So be careful.

I have added the ability to view the debug.log from the interface with the KanboardSupport plugin.

1 Like