iCal data with duedate only


On the other hand millions and millions of users. Simply not able to ignore them. Same as with ?SFck InternetDesplorer

Did you succeed with your calendar mess?

Not until now. I will investigate further next week.

I’am trying to understand how the eluceo ical lib works and compare in deep what i get on the prod and on the staging system.

I suppose that one of the calendar plugins added an option which is still set, even that the plugin is removed (i have no calendar plugins in use at the moment, but a tried a few).

But this is pure speculation.

I have to fix this or find out. If i will keep this thread updated.

Cheers, Fx

Hi @alfredb,

regarding the double entries on the prod system (it is in a first internal test setup, therefore only a few entries in there). Maybe it has something to do with the timezone. The server has an incorrect TZ (UTC).

I raised that issue here and awaiting a correction.

This is what Outlook shows for each task that has double entries. e. g. Task ID 10 is in Line 51 and repeats in Line 405 in the ics Text file.

It is for sure, that the iCal Lib eluceo writes doubles to the ics file.

But: not all tasks have double entries. One (and only one) has only one entry in the calendar. I could still not figure out where the difference is.

I will investigate further and keep it up to date here.

If anyone has additional hints: very welcome!

Cheers, Fx

I do not understand whats going on, but i think i found what’s going on:

The prod system uses mySQL, Staging / Test is on sqlite db.

This are two example tasks in prod:

As you can see the second entry (id = 96) has no date_started set. The record with id=20 has a such a date.

Task # 20 ist displayed once
Task # 96 is displayed twice

on the mySQL based system.

On the sqllite based system it simply does no matter. No double entries in the ics file. No double entries in the calendar. Regardless what’s in date_started.

On the prod: As son as i change the value for date_started and do a calendar refresh i see the changes (one entry vs. two entries).

Any ideas?

Cheers, Fx

I don’t have any doublets, not with SQLite not with MySQL.

Do you use a calendar plugin?

Have you really seen this in the ICS file?
Maybe OL starts stuttering…

No, but there is no VTIMEZONE component added to the calendar. It would be required for a proper validation. But this shouldn’t double an VEVENT components.

Please try this: Disable the TZ insertion by adding a line $vEvent->setUseTimezone(false); in file ICalFormatter.php.

diff --git a/Formatter/ICalFormatter.php b/Formatter/ICalFormatter.php
index 68ba9fe..5b358d5 100644
--- a/Formatter/ICalFormatter.php
+++ b/Formatter/ICalFormatter.php
@@ -51,6 +51,7 @@ class ICalFormatter extends TaskICalFormatter
             $end->setTimestamp($task[$endColumn] ?: time());
             $vEvent = $this->getTaskIcalEvent($task, 'task-#'.$task['id'].'-'.$startColumn.'-'.$endColumn);
+            $vEvent->setUseTimezone(false);

Then let OL fetch that modified calendar.

I had one or two installed, but i removed them. I can not say for sure if there are not still side effects because of former database changes of this plugins.

Yes, for sure. I download the ics file from the overview page of the board settings and open it with VSCode. It contains double entries. Absolut sure.

Outlook on my test / staging (sqlite) shows no double entries.

I will do that and respond. But i’am not sure if my guess that it may be TZ related is still the right direction.

Thanks for your help! :sweat_smile: :+1:

While thinking about possible scenarios for your issue: Please compare any doublet from your ICS file. Does the UID line match, means you have exactly the same UID twice in your ICS file?

Hi alfredb,


I’ve attached a flie which i cleared from personal data. I did it very, very carefully. Promise.

My view is:

Line 1-6 incl. and
Line 175 until EOF

are the correct parts of that file (or what i would expect to get). The part from
Line 7 to 174 incl.

is double / should not be there.

e. g.


is in the lower part of the file (and only there) and is correct.

whiel (e.g.)

is two times in the file. And the first occurence is wrong / double

Download Zip with ics file

Cheers, Fx

I think I got it! Means I could reproduce the dupes.

Make sure that the setting

$this->configModel->get('calendar_project_tasks', 'date_started');

is really on date_started. If it is set to date_due, you’ll get the issue.

I hope it’s really the same at your site.

1 Like

Great news!

Thanks for your help and investigating that issuse further.

I will test that as soon as possible. I hope tomorrow!

Cheers, Fx

1 Like

After further reading: is this a config.phpsetting? Or where have i to doublecheck this?

Cheers, Fx

It is AFAIK only modified by the calendar plugin. If you don’t have, fix it in the settings table of the DB.

1 Like

Hello @alfredb,

i changed the options in the settings table of the prod Kanboard installation to this new settings:

and finally: IT WORKS! :+1: :smiley:

Yes! All doubles are gone with this setting. Thank you very much for your time to investigate this extrem annoying issue! I suppose the existing settings came from one of my calendar plugin tests. This were the leftovers.

Cheers, Fx

1 Like

Are you still working with my ICalConfig?

Oh, yes! On all instances :smile:

Cheers, Fx

1 Like

I would like to suggest to do release it on Github and the official plugins list.

If i can help or assist (translation, documentation,…) just let me know.

Cheers, Fx

FYI, I just opened an issue at the upcoming ContentCleaner plugin from @aliawaid.