[newbie] Install with MySQL still use SQLite

Hi, I’ve just installed Kanboard on a WinS19/PHP7.3/MySQL5.7.28/Apache2.4.41.
I used the default config changing to define(‘DB_DRIVER’, ‘mysql’); and relative parameters.
I create the mysql db loading the app\Schema\Sql\mysql.sql file.
When I login and go to User/Settings/Informations the DB driver is still sqlite.
I googled without success.
The only suspect is that I have to migrate the “original” sqlite db to mysql.
Probably I’m loosing some step.
Thanks in advance for help.

Hi Stefano,

i think you are on the right track. It is a while ago we did this ourselves.

Maybe this helps you out:

Kind regards,


if you change the config to use mysql, then it should use mysql. plain and simple. if it shows that the db driver is still sqlite, the first place I’d look is cache. is your server caching php? if it is, doesn’t matter what php you change or modify, it’s cached…

Thanks @creecros for the suggestion. I did some try to clear the cache with htcacheclean.exe and restarted all service but without succes (tested multiple parameter option without success, I have to investigate).
I’m tempted to do a new installation and change the configuration before the first access.

Thank @sebastian. As soon I have solved the problem with the cache I will try.

might help.

I usually add a line and modify in the local.ini file for php7, turn on timestamp validation, and add revalidate freq with value of 0. I only do this when I am actively working on code though, caching php is pretty standard.

a server restart doing nothing clears the cache for me though.

Guys I truly apologize. The problem was on the file name: “config . . php”.