Project settings > allow only one subtask : "save" unvailable

Hi,

I’m a new user in Kanboard with Framaboard.

When user is allowed to do subtask one by one, he obtains the following webpage (with Firefox or Chrome) and he can’t save his choice :

CE2

I’m very interested in any progress on this.

Thanks a lot in advance for your return.

If you’re interested in progress, you should try the latest version of Kanboard, version 1.2.11.

Framaboard is KB version 1.0.47 I believe, so lot has changed.

You can see the changelog here: https://github.com/kanboard/kanboard/blob/master/ChangeLog

Thanks for your return. What is the procedure for trying the version 1.2.11 ?

Well, you would need to download and install on a server.

I have a test server however, running here: https://projects.nachostudio.ml/

User/PW = admin/admin

Feel free to demo.

I tried it, but I’m not able to use a server, I can only use an existing service as Framaboard.

If you have a computer, you have the ability to serve such a service. You just need the knowledge of how to do it.

It makes no sense troubleshooting an old version of kanboard, the issues most likely have been addressed at this point, and if not, any changes made would do you no good, until Framasoft updates their KB version to serve you.

I wish there was more we could do for you.

I well undersand but I will be not able to do this.

I agree, I will try to contact them and I hope that upgrade could be done.

Thanks a lot.

Hi,

According to other replies I received, tests of update should be done (in progress from few weeks).
Have a nice day.

Hi @creecros

I tested this option on https://projects.nachostudio.ml/ and also with Framaboard (using 1.2.11 version now) but it doesn’t work. I can’t validate the choice.

I’m still very interested in any progress on this.

Thanks a lot in advance for your return.

Can you explain what your doing, I don’t seem to understand

Hi @creecros

My question dealt with this part of the documentation : https://docs.kanboard.org/en/latest/user_guide/settings.html

I can enable this option, it works, but when the dialog box appears, users can’t save their choice (“save” or “cancel” doesn’t appear on web page) ? As a result, the situation is blocked.

You’ve found a bug!
Report it as an issue on github, please.

Thanks for your answer, I will do that.

Testing I found out that the issue happens if you click on the icon. If you click on the text (subtask name), it does not happen.

Fixed:

Hi @rafaelcamargo

I tried on Framaboard and the same thing appears.

Please, could you explain me what does your following message mean ? I’m not used to using this.

I’ve submitted a fix and it will be available on next kanboard release.
You can also run kanboard from latest (master) and don’t need to wait for releases.
You will have to wait framaboard to update their kanboard instances to get the fix.

I just tested on framawork and the workaround works fine.

If you click here, it will misbehave:
Screenshot%20from%202019-10-16%2015-11-07

If you click on the title, it will work:
Screenshot%20from%202019-10-16%2015-11-54

Hi @rafaelcamargo

Thanks for your return and the fix submission.

Have a nice day.