Kanboard 1.2.36: Plugin MarkdownPlus 1.1.4 destroys View for Tasks with Comments

For my installation

Application Config:

  • Version: 1.2.36
  • PHP Version: 8.3.6
  • PHP SAPI: fpm-fcgi
  • HTTP-Client: cURL
  • OS Version: Linux 5.4.0-181-generic
  • Database Driver: mysql
  • Database Version Version: 10.5.23-MariaDB-1:10.5.23+maria~ubu2004-log
  • Tons of Plugins
  • Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0
  • Installed on web server at all-inkl.com

and 3 other ones on same web server, failed. I followed Update instructions:

  1. Did Backup of complete KANBOARD to my HDD, afterwards Renamed old installation on server
  2. unzipped new version from gitnub on my HDD
  3. Renamed to Name of KANBOARD installation
  4. Uploaded to Webserver
  5. Uploaded data folder to webserver
  6. uploadet all plugins
  7. Did some tests.

After some first tests it looked as if everything woks fine.

Symptoms:

Comments destroy view on screen. I can add a first new comment to a Task, but then task looks so:


Page view is completely destroyed!

Never saw that in upgrades before. Any Ideas?

CU

Rainer

1 Like

I had to downgrade to backuped version of my KANBOARDS (2.33 … 2.35)

Well, so I will have to go the hard way. New KANBOARD, step by step …

My STR:

  1. Clean new installation 1.2.36
  2. Uploaded Data
  3. installed Plugin “Wiki”, did some Tests (incl. Comments view and creation), work fine.
  4. installed Plugin “Task2pdf”, did some Tests (incl. Comments view and creation), work fine.
  5. installed Plugin “Subtaskdescription”, did some Tests (incl. Comments view and creation), work fine.
  6. installed Plugin “Registration”, did some Tests (incl. Comments view and creation), work fine.
  7. installed Plugin “PluginManager” , did some Tests (incl. Comments view and creation), work fine.
  8. installed Plugin “PITM” + MarkdownPlus, did some Tests (incl. Comments view and creation), most works fine, but Comment view Problem appears :disappointed_relieved:!
  9. UNinstalled Plugin “PITM”, Comment view Problem remains :disappointed_relieved:!
  10. UNinstalled Plugin “MarkdownPlus”, Comment view Problem disappeared :ok_hand:!

Of course this might be some bad interaction with other Plugins, we need a test with a clean new KANBOARD installation.

Now I uninstalled Plugins one by one

until only MarkdwonPlus remained. Comment problem remained :disappointed_relieved:.
Then I removed the last remaining Plugin MarkdwonPlus: Problem vanishes. :ok_hand:

Hey Rainer,
AFAIK, the commenting-feature is still broken in 1.2.36. I had to switch back to 1.2.35 until it’s completely fixed.

1 Like

Seems so.

My last test for now:

  1. Uploaded unzipped 1.2.36
  2. Upload Config.php to Installation
  3. Launch KANBOARD, I see my tasks because of existing database, Comments look fine.
  4. I upload Plugin MarkdownPlus: Comments broken :disappointed_relieved:

So I will do update to 1.2.35 where necessary and stay on that version for now.

Did I miss something, where could I have read abotu this problem (and may be others) with 1.2.36??

It is marked as closed, but there isn’t a new release of Kanboard available.
So in case you want it, you’ll have to patch your installations.

Well, I don’t know any user friendly instruction how to verify that Kanboard is correctly installed.

I’m afraid, there isn’t one at all.

May be we can create some hints? Hints by you, I test whether a user can understand? May be based on these instructions?

Out of curiosity, I’ve repeated your tests with Kanboard 1.2.36, but I’ve applied the Patch for the comment bug. The commenting works now, as promised, but MarkdownPlus is now completely broken.
I still cannot use Kanboard 1.2.36 for develop nor productive tasks. Commenting, MarkdownPlus and PITM are all strong requirements, I cannot drop any of them.

1 Like

Same here, MarkdownPlus and PITM are essential for my KANBOARD use.

1 Like

Heloo! I have the same issue. Thank you so much for reporting!
If you uninstall “MarkdownPlus”, and “PITM”, does the KB still works?
Is there a way to just disable and not uninstalling this plugins?

No, unfortunately there is none.

Still the same issue with Kanboard 1.2.37. As soon a task gets a comment, any styling in completely lost.

I got it fixed for me, just submitted a pull request. :wink:

For me the problem became resolved with these modifications in MarkdownPlus file MarkdownPlusHelper.php.