[SOLVED] Share localhost from Laragon/Apache to other devices locally


I’ve installed Kanboard on Laragon via Apache. I can access it via Laragon, and also via Ipv4 on the same computer.
However, I’m not able to gain access via other devices connected to the same local network. I’m not able to figure out what should I enable to work it properly. I’ve tried to enable port 80 in Firewall, but it didn’t help.
When I want to open the address of Kanboard with Ipv4, it shows:

The connection has timed out

The requested site did not respond to a connection request and the browser has stopped waiting for a reply.

Thanks for your help

First off, I don’t know anything about Laragon; thus I won’t be able to help you there.
But your issue is rarely Kanboard related, it’s a pure networking issue. Rewriting, routing, firewall, who knows. You should publish more details about your network.

Laragon is just a tool that includes Apache, PHP, and other different tools to make apps work easily without additional settings. So my issue is probably with Apache on which Kanboard is running. I’m not sure which information should I provide. I’ve tried to enable port 80 (add inbound, and outbound rule), but it didn’t help. In hosts, there are “” with sites hosted with Laragon/Apache (i.e. “Kanboard.test”, which works but only on my computer, not for any other devices in the same network).

How about port forwarding? Beware, some providers don’t allow the use of port 80.

EDIT: I just saw that it’s with internal LAN connections. Sorry.

I’ve successfully solved it by myself :). Thanks again for your help, alfredb. I appreciate it.

I had to delete all inbound rules in regard to Apache (in “Windows Defender Firewall with Advanced Security”), then restarted the Apache server and then enable an access also to private/local network:

And also I had to check IPv4 address again since it changed automatically during managing Apache in firewall and restarting. Now it works as expected ;).

1 Like